Back to overview
Resolved

Cool Popup Email Reports is down

Aug 20, 2026 at 1:52am UTC
Affected services
Cool Popup Email Reports

Resolved
Aug 20, 2026 at 1:54am UTC

Cool Popup Email Reports recovered.

Created
Aug 20, 2026 at 1:52am UTC

Cool Popup Email Reports is degraded.